Can't set path options for Camera stills and streams

Hi, i was trying to set the path for storing my camera stills to a path other than the default /MyCodo/cameras//still… but it doesnt seem to be taking. After I click Save on the Camera (PiCamera in my case) settings, the Still Image Path and Video Path are blank and I confirmed it is still writing to that default directory. Any ideas?

thanks, really loving MyCodo for my home hydroponics setup!

1 Like

Hi Justin. This has been fixed and will be available in the next release. See the changelog for a full list of changes. If you would like to test the yet-to-be-released version, you can upgrade to master.

Hi Kyle, thanks for the update, I’ll definitely upgrade and provide feedback on your next release!

1 Like

Hi Kyle, I upgraded to your master and the camera path is setting correctly now. However, now the camera will not render an image on any dashboard, just a broken link image is displayed. I verified the camera is working and creating images in my new path but they wont display on any dashboard. This is easy to repro. Create a new dashboard, add the Camera widget and Save.

Here’s my relevant info:

Platform: “Raspbian GNU/Linux 10 (buster)”

Repro:

  1. Add Camera and specify ‘PiCamera’
  2. Create Dashboard or navigate to existing (repros either way for me)
  3. Add Camera Widget to Dashboard, Save.
  4. Widget will display broken link when rendered.

Thanks!

Also, couldnt locate an info on downgrading or reinstall. Any guidance you can share to get me back to current release? Worse case, I’ll backup and blow it away.

thanks!

Thanks. I’ll look into developing a fix for the widget.

See the manual Upgrade/Backup/Restore - Mycodo

Thank you, lmk if I can provide any further info

I just pushed a fix to master, if you would like to test.