L298N "output not set up"

Hi there, I’m sorry and I bet this is something simple, but I’m stuck.

I am trying to add an L298N with IN1, 2, 3, and 4 as BCM pins 17, 27, 22 and 23 respectively.

I added the Output and saved this pin configuration - I did not specify any Enable pins, as my L298N breakout has those as permanent jumpers that are manually set.

I rebotted the system after adding the Output, but I still can’t toggle any of the channels - I get the error “Output not set up”

My setup is pretty bare-bones - only Inputs are CPU and GPU temperature, and the L298N is the only Output. It’s a Raspberry Pi Zero W on standard Raspbian and Mycodo is 8.9.2

Here’s the log output right after startup:
2021-04-28 02:04:29,323 - INFO - mycodo.daemon - Mycodo daemon v8.9.2 starting
2021-04-28 02:04:39,038 - ERROR - mycodo.outputs.dc_motor_l298n_40239f23 - Cannot initialize Output channel 0 until all options are set. Check your configuration.
2021-04-28 02:04:39,061 - ERROR - mycodo.outputs.dc_motor_l298n_40239f23 - Cannot initialize Output channel 1 until all options are set. Check your configuration.
2021-04-28 02:04:39,063 - INFO - mycodo.outputs.dc_motor_l298n_40239f23 - Initialized in 2169.0 ms
2021-04-28 02:04:39,065 - INFO - mycodo.controllers.controller_output - Activated in 6000.8 ms
2021-04-28 02:04:39,568 - INFO - mycodo.daemon - All activated Conditional controllers started
2021-04-28 02:04:39,569 - INFO - mycodo.daemon - All activated Trigger controllers started

…any ideas? Thanks in advance for any assistance you can provide!

AKA

The current iteration of the Output requires the Enable Pin to be set. I can make the Enable Pin optional, but in the meantime, you can set it to a pin not in use and it should allow the output to function.

1 Like

Thanks so much for the super-quick solution, I knew I’d seen you say this somewhere before but couldn’t find it. Supplying some idle pins solves my problem and I’m back up and running, thanks again!

1 Like

You’re welcome. And since I happened to have my IDE open, I just added the option to disable the Enable Pin. This is untested, but should work. Let me know if you test it and there’s an issue.

1 Like