No measure value in EC

I don’t get any value on the EC measurement. I do have connection but it seems to be zero
I’ve made the calibration that seems to work.
1—
Entering value for calibration:
Low Solution
12880
High Solution
80000
2—
Success: EC Calibration: ec_dry (None \u03bcS):
Success: EC Command: continuous:
3—
EC Solution: 12880 \u03bcS
Latest EC measurement: 0.00
Success: EC Calibration: ec_low (12880 \u03bcS):
Success: EC Command: continuous:
4—
Latest EC measurement: 0.00
Success: EC Calibration: ec_high (80000 \u03bcS):
Success: EC Command: end:

Should the measurement value be 0,00 and is it correct to add in first step 12880 not 12,880 ?

The live page after this is:
Atlas EC (Input 3fd51e7e)
Input (ATLAS_EC), 15.0 second interval
Measurement | Timestamp
0 \u03bcS/cm (Electrical Conductivity) CH0 | 2021/6/3 21:46:55

1 Like

Are you able to obtain meansuringments using any acquisition hardware (e.g. Arduino)?

A Success response does not mean it was successful in calibrating, but the frontend initiating the command (in this case, a specific calibration command). The output (in parentheses) does not look like it was successful. You should review the Daemon Log for errors.

Sorry I’m not able to do measurement on other hardware, just have my raspberry.
The only error I can see in the Deamon log is for the PH (but that seems to work properly) and some pump?

Log:
2021-06-03 22:04:21,501 - ERROR - mycodo.outputs.pump_atlas_ezo_pmp_7d8a9d17 - Invalid parameters: State: on, Type: sec, Mode: fastest_flow_rate, Amount: None, Flow Rate: 10.0
2021-06-03 22:04:26,505 - ERROR - mycodo.outputs.pump_atlas_ezo_pmp_7d8a9d17 - Invalid parameters: State: on, Type: sec, Mode: fastest_flow_rate, Amount: None, Flow Rate: 10.0
2021-06-03 22:04:28,455 - ERROR - mycodo.inputs.atlas_ph_7ffc270e - Sensor read unsuccessful: 254
2021-06-03 22:04:28,456 - ERROR - mycodo.inputs.atlas_ph_7ffc270e - Cannot set a value of None. Must be a float or string representing a float. Check the sensor and Input module is working correctly.
2021-06-03 22:04:28,942 - INFO - mycodo.devices.atlas_scientific_i2c_100_1 - Atlas Scientific Board: EC, Rev: 2, Firmware: 2.15
2021-06-03 22:04:30,449 - INFO - mycodo.controllers.controller_input_3fd51e7e - Activated in 2384.5 ms
2021-06-03 22:04:31,463 - ERROR - mycodo.outputs.pump_atlas_ezo_pmp_7d8a9d17 - Invalid parameters: State: on, Type: sec, Mode: fastest_flow_rate, Amount: None, Flow Rate: 10.0
2021-06-03 22:04:36,203 - INFO - mycodo.controllers.controller_input_6864ade2 - Deactivated in 20.2 ms
2021-06-03 22:05:58,373 - ERROR - mycodo.inputs.atlas_ph_7ffc270e - Sensor read unsuccessful: 254
2021-06-03 22:05:58,374 - ERROR - mycodo.inputs.atlas_ph_7ffc270e - Cannot set a value of None. Must be a float or string representing a float. Check the sensor and Input module is working correctly.
2021-06-03 22:06:47,373 - INFO - mycodo.controllers.controller_input_3fd51e7e - Deactivated in 93.1 ms
2021-06-03 22:07:28,441 - ERROR - mycodo.inputs.atlas_ph_7ffc270e - Sensor read unsuccessful: 254
2021-06-03 22:07:28,443 - ERROR - mycodo.inputs.atlas_ph_7ffc270e - Cannot set a value of None. Must be a float or string representing a float. Check the sensor and Input module is working correctly.
2021-06-03 22:09:43,459 - ERROR - mycodo.inputs.atlas_ph_7ffc270e - Sensor read unsuccessful: 254

not sure if the incorrect db version acn make any sense

Mycodo Version: 8.10.1
Python Version: 3.7.3 (default, Jan 22 2021, 20:04:44) [GCC 8.3.0]
Database Version: 43c72773dbe8 (Incorrect Version. Should be 45d5ab26ca82)

Is it in I2C mode? If not, switch to I2C mode. Is the address appearing in the i2c-detect device tree?

You refers to this right?
0 1 2 3 4 5 6 7 8 9 a b c d e f
00: – – – – – – – – – – – – –
10: – – – – – – – – – – – – – – – –
20: – – – – – – – – – – – – – – – –
30: – – – 33 34 35 36 – – – – – – – – –
40: – – – – – – – – – – – – – – – –
50: – – – – – – – – – – – – – – – –
60: – – – 63 64 – 66 – 68 – – – – – – –
70: – – – – – – – –

I have numb. 64 for that. I have the blue light on carrier board so it should be I2C

So if you disconnect the sensor, that address dissapears from the device tree?

Please post a screenshot of your Input settings.

I just tried to remove pin for VCC on the carrier board for EC and now I just have the 63 in the tree, that is PH sensor.
Seems to be strange.
i’ll guess you don’t mention deactivate sensor

Not sure what the issue could be. I would try to run Atlas Scientific’s Python code they provide and see if it can acquire a measurement. If not, then you should probably contact Atlas Scientific so they can diagnose a potential hardware issue with their product.

Have you tried attaching only the EC sensor?

I had issues with my atlas sensors after to many devices were on the same bus. Solution was to move all atlas devices to a seperate bus.

I’ve right now tried to just have the EC sensor attached.
Measurment is still zero in my nutrient water.


I was now trying with Atlas instructions to calibrate ad connect with commads, it seems that i anyway getting value zero.
image

Could it be hardware issue?, isn’t it only PH sensor that should not get dry?

You should not concern yourself with calibrating until you get the sensor working. Once you can obtain a measurement, then calibration will be useful.

Yes

There are many sensors that should not be left dry, but Electrical Conductivity probes are not damaged by being exposed to the air.

Reach out to Atlas support and see if they cant help you out

1 Like

I’ve been in contact with Atlas and they are telling me to do a read between every calibration. That I’ve done now but it seems to be big variation in every measurement then. Have you seen this graph before, if you know what can be wrong?
My pump will getting crazy if I enable them to the nutrients :slight_smile:

Do you mean temperature compensation? You can’t realisitcally calibrate between every measurement reading.

No temperature conpensation
They where writing:
” It looks to me like you are using the equipment incorrectly.
We tell you in the datasheet to take readings during the calibration process so you can see what’s going on.”

I’ll guess they refere to the instruction on page 14

But I’ve tried both there python app and from mycodo calibration.
My graph is jumping like a frog. From your screen shot it looks like that is smooth

Yes, you must have the Input activated in order to calibrate. You should turn down the Period so your measurement rate is high so you know when the measurements are stabilizing. Only when the measurements are stable with the probe in the calibration solution should you actually calibrate. Is this how you’ve been calibrating?