Atlas PH/EC Input errors - no measurements

Hi
I’m not able to get any input from the EC PH temp…
The environment in new installed, I have converted to I2C, is it something I’m missing during add input hardware.
The log is:

2021-05-10 16:27:23,541 - ERROR - mycodo.inputs.atlas_ph_82c883da - Input not set up
2021-05-10 16:27:23,996 - ERROR - mycodo.inputs.atlas_ec_a8187d28 - Input not set up
2021-05-10 16:27:24,368 - ERROR - mycodo.controllers.controller_input_9a3c8d14 - Mycodo is attempting to acquire measurement(s) from an Input that has already critically errored. Review the log lines following Input Activation to investigate why this happened.
2021-05-10 16:27:38,575 - ERROR - mycodo.inputs.atlas_ph_82c883da - Input not set up
2021-05-10 16:27:38,576 - ERROR - mycodo.controllers.controller_input_82c883da - StopIteration raised 3 times. Possibly could not read input. Ensure it's connected properly and detected.
2021-05-10 16:27:38,930 - ERROR - mycodo.inputs.atlas_ec_a8187d28 - Input not set up
2021-05-10 16:27:38,930 - ERROR - mycodo.controllers.controller_input_a8187d28 - StopIteration raised 3 times. Possibly could not read input. Ensure it's connected properly and detected.
2021-05-10 16:27:39,401 - ERROR - mycodo.controllers.controller_input_9a3c8d14 - Mycodo is attempting to acquire measurement(s) from an Input that has already critically errored. Review the log lines following Input Activation to investigate why this happened.
2021-05-10 16:27:43,411 - ERROR - mycodo.controllers.controller_input_9a3c8d14 - Mycodo is attempting to acquire measurement(s) from an Input that has already critically errored. Review the log lines following Input Activation to investigate why this happened.
2021-05-10 16:27:53,610 - ERROR - mycodo.inputs.atlas_ph_82c883da - Input not set up
2021-05-10 16:27:53,965 - ERROR - mycodo.inputs.atlas_ec_a8187d28 - Input not set up
2021-05-10 16:27:58,445 - ERROR - mycodo.controllers.controller_input_9a3c8d14 - Mycodo is attempting to acquire measurement(s) from an Input that has already critically errored. Review the log lines following Input Activation to investigate why this happened.

Have you reviewed the log lines following Input Activation? I don’t see the “Input Activated” lines in the excerpt you pasted. If a controller has an issue, it will likely occur during or immediately after activation. If you are viewing recent log lines, this gives no indication what occurred around the activation time.

It seems like it’s missing file/directory, how can I add that?

2021-05-10 20:17:41,931 - ERROR - mycodo.devices.atlas_scientific_i2c_100_1 - AtlasScientificI2C raised an exception when initializing: [Errno 2] No such file or directory: ‘/dev/i2c-1’
Traceback (most recent call last):
File “/var/mycodo-root/mycodo/devices/atlas_scientific_i2c.py”, line 35, in init
self.file_read = io.open("/dev/i2c-" + str(i2c_bus), “rb”, buffering=0)
FileNotFoundError: [Errno 2] No such file or directory: '/dev/i2c-1’

I think I found the solution:
raspi-config → Interfacing Options → I2C - > Enable :slight_smile:

2 Likes